We have reversed almost all the incorrect enrolments for impacted organisations but will do a recheck tomorrow to ensure none were missed. Approximately a dozen organisations had 2-5 modules impacted, so the issue was relatively contained. Nevertheless, we apologise for the confusion to learners caused by this and will be compensating for any unnecessary logins by users for subscriptions. We will conduct a review of how this specific error on Monday to expand our test coverage to ensure it does not occur again. Thank you again for your understanding.
Posted Mar 29, 2025 - 21:23 AEST
Identified
We have identified the issue - an error in code has meant that automated rules which included our Roles feature in the rule have been triggered for users without that Role. This means that for most organisations, there is no impact here (since it requires the use of Roles, assigning those Roles to rules and activating those rules for automated enrolments). For the few impacted organisations, we are currently reversing these enrolments.
Posted Mar 29, 2025 - 15:14 AEST
Investigating
We have had a bad deployment today which appears to have triggered some automated enrolments rules to run and create enrolments for learners who should not have received those enrolments. We are investigating now.