Enrolments via API are failing
Incident Report for Tribal Habits
Resolved
We have verified the fix is working. Once again our apologies for this bug today.

For Zapier integrations. If your Zap involved both creating a new user and then enrolling them into training, the new user creation was still working. Unfortunately, however, the enrolment step would have failed. We recommend reviewing the history of your Zaps today and for each failed enrolment, you will need to manually enrol the user in your portal (the user would have been created, but the enrolment will be missing).
Posted Oct 20, 2023 - 17:24 AEST
Monitoring
We have just deployed the fix to production and are now monitoring API calls to ensure success.
Posted Oct 20, 2023 - 16:36 AEST
Update
We have successfully tested a fix and are preparing for deployment to production.
Posted Oct 20, 2023 - 15:00 AEST
Update
We have identified the bug and are testing a fix.
Posted Oct 20, 2023 - 14:46 AEST
Identified
We have identified an unintended bug in our API which started at about 10:30 pm AEST Thursday 19th October. A small change to our API has accidentally impacted other parts of our API and prevented them from working. In particular, the topic_assignment PUT is not working. This means that any new topic or pathway enrolments created via API since this bug have not occurred. This will include enrolments via Zapier as well as other API integrations.

We sincerely apologise for this unintended bug. Our team is correcting the situation now and we will deploy a fix to our production environment as fast as possible today (ideally before 6 pm AEST). We will update this incident as we progress.
Posted Oct 20, 2023 - 14:09 AEST
This incident affected: Front End User Servers.